전체 글 324

The style on this component requires your app theme to be Theme.MaterialComponents (or a descendant)

com.google.android.material.bottomappbar.BottomAppBar material 을 사용 할 때, material 테마를 적용 해주시 않으면 아래와 같은 에러가 나온다. The style on this component requires your app theme to be Theme.MaterialComponents (or a descendant) layout.xml 과 style.xml에 아래와 같이 수정 해준다. 1. layout android:theme="@style/MaterialTheme" 2. style

Inheritance from an interface with '@JvmDefault' members is only allowed with -Xjvm-default option

Inheritance from an interface with '@JvmDefault' members is only allowed with -Xjvm-default option viewModel 에 param을 추가하였더니 viewModel Factory가 필요하고, 추가 하니 위와 같은 에러가 나왔다~ 버전 충돌 문제인데~ build.gradle.app 에 kotlinOptions { jvmTarget = '1.8' freeCompilerArgs += [ '-Xjvm-default=enable' ] } 또는 tasks.withType(KotlinCompile).configureEach { kotlinOptions { freeCompilerArgs += [ "-Xjvm-default=all", ] } }..

애플 시리 호출 안되는 현상 -사춘기 시리

보통 시리 호출이 안될 때는 아래 2가지를 기본으로 확인 해야 한다. 1. 마이크 작동 여부 2. 시리 설정 여부 Just Turn Off Siri on iCloud setting and reBoot and turn on Siri on iCloid again. 위 사항이 잘 체크 되어있는데도 키보드 눌러서 호출은 되고~ 직접 말로만 시리 호출이 안된다면 >>> 로그아웃 후 다른 계정으로 로그인해서 시리 호출 했을 때 정상이라면 애플 클라우드 계정이 꼬였다는 의미다!! 1. 설정 > 애플 아이디 > iCloud로 가서 Siri 를 끄고 재부팅 한 뒤, Siri를 다시 킨뒤 2. 설정 > 시리로 가면 꺼져있는 시리를 다시 키면, 다시 시리를 초기화 하는 화면이 뜬다. 안녕, 시리, 내일 할일은 뭐야등등 다시..

[애플] 2023.06.09

Resource IDs will be non-final by default in Android Gradle Plugin version 8.0, avoid using them in switch case statements

switch 문에서 case R.id.xxxx 를 더 이상 제공 하지 않는다고 한다. 간단하게 if else 문으로 대체 하면 되는데 case 문이 많을 경우 난감하고 귀찮다. 이럴 때는 간단히 Refactoring 을 하면 된다. switch 에 커서를 올리고 Option(Windows Alt) + enter 를 치고 Replace switch with if 를 선택하면 한 방에 해결 된다.

bitbucket 계정 비밀번호(github 토큰) 설정 방법

Update failed Invocation failed Unexpected end of file from server java.lang.RuntimeException: Invocation failed Unexpected end of file from server Git 사용 시 이런 에러가 나타나면 앱 비밀번호를 생성 해주어야 한다 Github 에서는 토큰 생성하고, 메뉴에서 직접 입력 하면 되지만 Bitbucket에서는 안드로이드스튜디오 > Git > Manage Remote 주소 입력에 비밀번호를 넣어줘야 한다. https://계정:비밀번호@bitbucket.org/project 끝.

Gradle 7로 업그레이드 시 발생하는 에러 com.github.dcendents.android-maven

에러 문구 A problem occurred evaluating project Failed to apply plugin 'com.github.dcendents.android-maven'. Unable to load class 'org.gradle.api.publication.maven.internal.MavenPomMetaInfoProvider'. 주로, 오래된 오픈 소스를 사용하다 보면 발생하는 문제. 오픈소스의 그래들이 업데이트 되지 않기 때문데 아래와 같이 직접 수정 해주어야 한다. 모듈 gradle 수정 사항 아래와 같이 순서대로 수정 하면 된다. 1. 아래 줄 삭제 apply plugin: 'com.github.dcendents.android-maven' 하고 apply plugin: 'mave..

안드로이드 스튜디오 빌드 10% 향상 시키기

Build Analyzer 를 실행 하면 아래와 같이 팁이 나타나는데, 따라 해주면 10%의 성능 향상이 기대된다고 한다. gradle.properties 에 org.gradle.jvmargs=-Xmx2048m org.gradle.parallel=true 에서 아래 라인을 추가 -XX:+UseParallelGC 하면 org.gradle.jvmargs=-Xmx2048m -XX:+UseParallelGC org.gradle.parallel=true 요렇게 되고, Build Analyzer를 다시 실행하면 위 팁이 사라진다.

Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8.

안드로이드 스튜디오 버전이 올라가면서, Gradle 버전이 7로 올라가면서 자바 11로 올려줘야 하는 문제. > Failed to apply plugin 'com.android.internal.application'. > Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. You can try some of the following options: Mac 은 AndroidStudio > Preference Window는 File > Settings 간단하게 11로 변경만 해주면 완료 된다.